Boot stucks at "Loading initial ramdisk"

Dileep Sankhla dileepsankhla.ds at
Fri Dec 22 06:32:52 EST 2023

Hi Bagas,

On Fri, Dec 22, 2023 at 12:24 PM Bagas Sanjaya <bagasdotme at> wrote:

> On Thu, Dec 21, 2023 at 05:58:23PM +0530, Dileep Sankhla wrote:
> > Hello,
> >
> > I have cloned and built the latest rc kernel using the default config but
> > on boot, it stucks at "Loading initial ramdisk". I have tried booting
> after
> > removing the "quiet" option from the kernel parameters just before
> > selecting the kernel from the grub menu. I have also tried adding
> > "dis_ucode_ldr" parameter to the initial parameters but all in vain.
> >
> For initramfs, make sure to follow instructions specific to your distro
> (search the web if you're unsure). For example, as I'm on Arch, I use
> mkinitcpio (see [1]) to generate initramfs after compiling the kernel.
On "sudo make install", I get an output line as "update-initramfs:
Generating /boot/initrd.img-6.7.0-rc6-test". I have not gone through
Makefile though. So I think I am using the right tool on my distro (Ubuntu
22.04.03 LTS).
As you suggested, I also manually deleted and created the image using
update-initramfs (see [1]) after compiling the kernel. Still the same

> Thanks.
> [1]:
> --
> An old man doll... just what I always wanted! - Clara


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Kernelnewbies mailing list