Boot stucks at "Loading initial ramdisk"

Bagas Sanjaya bagasdotme at
Fri Dec 22 01:54:28 EST 2023

On Thu, Dec 21, 2023 at 05:58:23PM +0530, Dileep Sankhla wrote:
> Hello,
> I have cloned and built the latest rc kernel using the default config but
> on boot, it stucks at "Loading initial ramdisk". I have tried booting after
> removing the "quiet" option from the kernel parameters just before
> selecting the kernel from the grub menu. I have also tried adding
> "dis_ucode_ldr" parameter to the initial parameters but all in vain.

For initramfs, make sure to follow instructions specific to your distro
(search the web if you're unsure). For example, as I'm on Arch, I use
mkinitcpio (see [1]) to generate initramfs after compiling the kernel.



An old man doll... just what I always wanted! - Clara
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <>

More information about the Kernelnewbies mailing list