Boot stucks at "Loading initial ramdisk"

Soumya Negi soumya.negi97 at
Fri Dec 22 03:54:49 EST 2023

Hi Dileep,

On Thu, Dec 21, 2023 at 05:58:23PM +0530, Dileep Sankhla wrote:
> Hello,
> I have cloned and built the latest rc kernel using the default config but
> on boot, it stucks at "Loading initial ramdisk". I have tried booting after
> removing the "quiet" option from the kernel parameters just before
> selecting the kernel from the grub menu. I have also tried adding
> "dis_ucode_ldr" parameter to the initial parameters but all in vain.
> How to look for the underlying issue and solve it?
> Regards,
> Dileep

I had this issue as well. I found a solution on stackexchange(..I think)
that I wanted to link here.. but can't seem to find it now. For reference, I
was using Ubuntu. This was my case:

* Possible reason - initrd.img file is too large
I checked the size of initrd.img-<kernel name> at /boot. The file was ~500mb,
much larger than the initrd for the kernel that came with Ubuntu(~40mb)

* Possible solution - 
Before installing the kernel, change  MODULES=most to MODULES=dep  in 
/etc/initramfs-tools/initramfs.conf to generate smaller initrd.img files.
The new initrd's for all other kernels I have installed afterwards have been

Soumya Negi

More information about the Kernelnewbies mailing list