Cannot boot to compiled kernel

Daniel Bokser dan.bokser at
Wed Nov 2 07:05:29 EDT 2016

Hi Everyone,

I know this is probably the newbiest of questions, but I am trying to compile and boot off of the kernel.  
I am running Arch Linux and I am following this guide:

Despite using "linux480" below (I tried this a few weeks ago), the kernel version I am using is
Linux 4.9.0-rc3 "Psychotic Stoned Sheep" (I love these names). I use systemd-boot as a boot loader.

1) Pulled down kernel from git
2) Ran make localmodconfig
3) Ran make menuconfig and changed the local version to a custom string
4) Ran make 
5) Ran sudo make modules_install
6) Ran sudo cp arch/x86_64/bzImage /boot/vmlinuz-linux480
7) Added /etc/mkinitcpio.d/linux480.preset,
    which is similar to linux.preset except with linux480 names
8) Ran mkinitcpio -p linux480
9) Ran sudo cp /boot/
10) Added entry file to /boot/entries called linux480 and used the current entry as a template
11) Rebooted and selected linux480

Now I am thrown into the recovery shell with an 'Unable to find root device /dev/sdc2' (my SSD).
The real strange thing is that the (PS/2) keyboard doesn't work, so I can't even run commands.
Tried also USB keyboard to no avail.
I also have a bunch of "Unknown symbol" errors from scsi_mod which fill most of the screen. 

I'm thinking the RAM disk is bad, but not sure. No amount of Google-fu was able to help me out with this one. 

Any help would be appreciated.  Thank you!


More information about the Kernelnewbies mailing list