Building Hello World LSM

Thomas F. J.-M. Pasquier tfjmp2 at
Tue Jan 20 03:43:37 EST 2015


I am able to re-build with SELinux now and that's working (using config
from /boot/). However, when building with helloworld LSM it does not seem
to be working. I can indeed see the "Security Framework initialized", but
none of the printk present in my module. I will be doing more test today.

I think LSM should not appear in modprobe as they are not loaded anymore.
Am I missing something or is this correct?


On Mon Jan 19 2015 at 3:45:15 PM Dave Tian <dave.jing.tian at> wrote:

> LSM does not support dynamic module loading now.
> I have tried to create a new LSM based on yama and boot it as the default
> on my Ubuntu 14.04 (kernel 3.13). It works smoothly. I have NOT tried
> Fedora with kernel 3.18 yet but I do not think there would be some changes
> breaking LSM, which has been there for years…Would you please recheck your
> Kconfig and Makefile? At least, you should see the logging “Security
> Framework initialized" from dmesg, saying the LSM is init’d, after which
> your LSM should be  loaded presumably.
> -daveti
> > On Jan 18, 2015, at 9:33 PM, Valdis.Kletnieks at wrote:
> >
> > On Sun, 18 Jan 2015 23:49:31 +0000, "Thomas F. J.-M. Pasquier" said:
> >
> >> I am trying to build a skeleton LSM module, but I am not having much
> luck
> >> so far. The problem seems to be that the LSM init function is never
> called.
> >
> > What does 'modprobe' report?  Anything in dmesg?
> > _______________________________________________
> > Kernelnewbies mailing list
> > Kernelnewbies at
> >
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Kernelnewbies mailing list