Building Hello World LSM

Dave Tian dave.jing.tian at
Mon Jan 19 10:45:08 EST 2015

LSM does not support dynamic module loading now.

I have tried to create a new LSM based on yama and boot it as the default on my Ubuntu 14.04 (kernel 3.13). It works smoothly. I have NOT tried Fedora with kernel 3.18 yet but I do not think there would be some changes breaking LSM, which has been there for years…Would you please recheck your Kconfig and Makefile? At least, you should see the logging “Security Framework initialized" from dmesg, saying the LSM is init’d, after which your LSM should be  loaded presumably.


> On Jan 18, 2015, at 9:33 PM, Valdis.Kletnieks at wrote:
> On Sun, 18 Jan 2015 23:49:31 +0000, "Thomas F. J.-M. Pasquier" said:
>> I am trying to build a skeleton LSM module, but I am not having much luck
>> so far. The problem seems to be that the LSM init function is never called.
> What does 'modprobe' report?  Anything in dmesg?
> _______________________________________________
> Kernelnewbies mailing list
> Kernelnewbies at

More information about the Kernelnewbies mailing list