Problem with booting using qemu

Mulyadi Santosa mulyadi.santosa at
Wed Apr 13 22:51:59 EDT 2011

Hi... :)

On Wed, Apr 13, 2011 at 11:27, Minwoo Lee <ermaker at> wrote:
> Hi, all.
> I want to study kernel, so I tried booting my custom compiled kernel
> on qemu with '-kernel' and '-initrd' option.
> First, I installed ubuntu 10.10 with cdrom, no LVM.
> $ qemu disk.img -cdrom ubuntu-10.10-server-i386.iso -vnc :1
> After installation, I tried booting my custom compiled kernel(but not
> modified, just compiled).
> $ sudo qemu -m 512 -enable-kvm disk.img -nographic -append
> "console=ttyS0 root=/dev/sda1 ro" -kernel bzImage -initrd
> initrd.img-2.6.37

Just to make sure few things:
1. are you really going to setup serial console only guest? because I
saw that nographic and console=ttyS0

2. and the initrd, is that the correct initrd that is built against your kernel?

> And I got result like this.
> [    2.687558] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
> [    2.688085] EXT4-fs (sda1): write access will be enabled during recovery
> [    2.691679] EXT4-fs (sda1): recovery complete
> [    2.944387] EXT4-fs (sda1): mounted filesystem with ordered data
> mode. Opts: (null)
> Begin: Running /scripts/local-bottom ... done.
> done.
> Begin: Running /scripts/init-bottom ... done.
> [    2.988413] e1000 0000:00:03.0: eth0: (PCI:33MHz:32-bit) 52:54:00:12:34:56
> [    2.988871] e1000 0000:00:03.0: eth0: Intel(R) PRO/1000 Network Connection

just a guess: maybe it didn't just display things but
toward serial console.... for a test, I suggest (untested) to dump out
-nographic and instead use buit in qemu serial console. Switch to it
by pressing Ctrl-Alt-3 and see if there are message showing there...


Mulyadi Santosa
Freelance Linux trainer and consultant


More information about the Kernelnewbies mailing list