Problem with booting using qemu

Minwoo Lee ermaker at
Wed Apr 13 00:27:08 EDT 2011

Hi, all.

I want to study kernel, so I tried booting my custom compiled kernel
on qemu with '-kernel' and '-initrd' option.

First, I installed ubuntu 10.10 with cdrom, no LVM.
$ qemu disk.img -cdrom ubuntu-10.10-server-i386.iso -vnc :1

After installation, I tried booting my custom compiled kernel(but not
modified, just compiled).
$ sudo qemu -m 512 -enable-kvm disk.img -nographic -append
"console=ttyS0 root=/dev/sda1 ro" -kernel bzImage -initrd

And I got result like this.

[    2.687558] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
[    2.688085] EXT4-fs (sda1): write access will be enabled during recovery
[    2.691679] EXT4-fs (sda1): recovery complete
[    2.944387] EXT4-fs (sda1): mounted filesystem with ordered data
mode. Opts: (null)
Begin: Running /scripts/local-bottom ... done.
Begin: Running /scripts/init-bottom ... done.
[    2.988413] e1000 0000:00:03.0: eth0: (PCI:33MHz:32-bit) 52:54:00:12:34:56
[    2.988871] e1000 0000:00:03.0: eth0: Intel(R) PRO/1000 Network Connection

After that, the machine just stopped and I don't know the cause.

What is the cause, or how to find the cause?

The whole log is in this url.

Thank you for reading.

More information about the Kernelnewbies mailing list