On 10/2/22 05:27, Valdis Klētnieks wrote:
Here some examples of the names I want to change. Why? What actual improvement would accrue from doing this?
Hi Valdis, thanks for your response. I am working on rtl8192e in the staging area. Reason is that the hardware is commonly available and this driver will be used a long time from now. This driver is not removed from the staging area without cleaning up checkpatch errors. Main issue with the long variable names is that the snake_case is making the names even longer. So when having a chance to shortem them this will improve readability for the bigger tasks.
(Hint: the code is almost certainly in drivers/staging because it has far worse issues than just using camel-case variable names...) Yes but we need to start somewhere. Yes I do like to do more than what I did so far (remove dead code, fix checkpatch errors, remove ftrace like logging) up to now.
Do you know what issues that are and a way to improve this? I do like to know what is next. Thanks for your support. Bye Philipp