June 17, 2011
6:53 p.m.
Hey Jonathan, On Fri, Jun 17, 2011 at 11:46 AM, Jonathan Neuschäfer <j.neuschaefer@gmx.net> wrote:
On Fri, Jun 17, 2011 at 06:18:06PM +0300, Metin KAYA wrote:
Jonathan, it's kmalloc(), not kcalloc().
No, I was trying to suggest using kcalloc(), which behaves roughly like the userspace calloc, and implements overflow checking, which you may need and zeroing, which you don't seem to need.
Cool - I missed that somehow. So we now have kmalloc, kcalloc, and kzalloc, and I see krealloc too. -- Dave Hylands Shuswap, BC, Canada http://www.davehylands.com