Kernel Compile Issue

Aruna Hewapathirane aruna.hewapathirane at
Mon Jun 28 07:58:11 EDT 2021

On Sat, Jun 26, 2021 at 2:39 AM Valdis Klētnieks
<valdis.kletnieks at> wrote:
> On Fri, 25 Jun 2021 16:05:45 -0400, Aruna Hewapathirane said:
> > Jun 25 10:46:42 debian systemd-modules-load[201]: Failed to find module 'vmhgfs'
> > Jun 25 10:46:42 debian systemd[1]: Failed to start Load Kernel Modules.
> > Jun 25 10:46:42 debian systemd[1]: Unit systemd-modules-load.service entered failed state.
> >
> > Does that make sense to you or anyone ?
> For reasons understandable only to systemd, it tried to modprobe vmhgfs and
> didn't find it in the initramfs.

I think I am beginning to understand what went wrong, I installed
VirtualBox and all
my troubles started after this. Everything was smooth until I tried to
compile a kernel.
This is when things went sideways. So if your going to be compiling
kernels stay away
from VirtualBox on Debian.

So as much as I do not care for systemd because it deviates from the
original philosophy of do one
thing but do that one thing really really well and better than anyone
else policy to do everything under
the sun ( and so far seems to do everything under the sun really
well). It was 'me' who did this 'not'
systemd. I am human, humans err ?

Systemd is impressive and scares me at times but then I guess it comes
down to personal choice ?
I keep asking myself 'if' something bad happens to systemd, what are
our options ? Think about it ?
It is not like tweaking init using text files and echo eh ?

> Does this configuration actually *need* a  vmware shared folder in order to boot?
Uh-uh no it does not.

I guess  it is looking for that 'vmhgfs' because I installed VirtualBox.
And something really interesting, I deleted VirtualBox or so I
thought. I recompiled the kernel
and checked, same 'bleeping' error. So reinstall VirtualBox and like
some Voo Doo magic all
my operating systems showed up which tells me Virtual Box keeps its
folder and settings in
your home folder. One lives and learns :-)

> If so, you'll need to tell your dracut/  mkinitramfs/whatever command to include it.
> If not, you'll need to tell it to not look for it.

oh-kay so here are the latest developments. I told initramfs to load
crc32c, told make menuconfig
to disable Virtualization then recompiled and re-test and my kernel
drops to a initramfs shell ( some progress yay )
then I ask initramfs to load 'vmhgfs' and it complains about 'can't
find module not in blah-blah' and reverts to the
original error, so I am back to square one.

sudo vim /etc/initramfs-tools/modules ( in Debian ) for anyone curious :-)

> (Particularly annoying -  dracut will include that systemd unit even if you
> have a kernel that doesn't need any modules to boot because all the requisites
> are built-in, you said --no-kernel to not include kernel modules in the
> initramfs, and you gave it -o "kernel-modules kernel-modules-extra kernel-network-modules"
> to omit those dracut modules from the run. I submitted a patch that was
> rejected, because apparently *some* places build an initramfs with 'dracut
> --no-kernel' and then append another cpio image that contains kernel modules,
> and the patch would break that.  This is why we can't have nice things.)
Valdis, if I apply that patch to 'my' kernel and it works then problem
solved right  ? What do you think ?
And you do have nice things my friend, remember a young lady some
years back wrote in her facebook...
"Drove a Jag, did not crash"  ? :-)

I am going to keep working on this as and when I have the time I want
to know how to fix this.
We know it is because I installed VirtualBox, now I gotta find a fix :-(

Thanks everybody - Aruna

More information about the Kernelnewbies mailing list