naming conventions

John de la Garza john at jjdev.com
Sat Jul 22 23:29:40 EDT 2017


Are there naming conventions that are preferred for functions?  I'm seeing
somethings named foo_free, free_foo, foo_init, init_foo, etc.

Consistency provides names that are easy to guess/learn.

examples from: linux/kernel/fork.c
####################################
static void free_thread_stack(struct task_struct *tsk)
{
        kmem_cache_free(thread_stack_cache, tsk->stack);                              
}

void thread_stack_cache_init(void)
{
        thread_stack_cache = kmem_cache_create("thread_stack", THREAD_SIZE,
                                              THREAD_SIZE, 0, NULL);                  
        BUG_ON(thread_stack_cache == NULL);                                           
}

if (init_new_context(p, mm))



More information about the Kernelnewbies mailing list