inittab is not executing after my Linux box boots up

Raseel Bhagat raseelbhagat at
Wed Jun 15 02:40:37 EDT 2011

On Tue, Jun 14, 2011 at 7:22 PM, Prajosh Premdas
<premdas.prajosh at>wrote:

> Hi Dave
> I tried booting with the root file system in my flash and uImage i copy
> using TFTP everything is fine.
> On Tue, Jun 14, 2011 at 10:49 PM, Dave Hylands <dhylands at> wrote:
>> Hi Prajosh,
>> On Tue, Jun 14, 2011 at 10:07 AM, Prajosh Premdas
>> <premdas.prajosh at> wrote:
>> > Hi
>> > I am stuck with a problem. inittab is not executing after my Linux box
>> boots
>> > up.
>> > The problem in detail. I have a linux box, i load the Linux image uImage
>> > using TFTP and my root file system is configured in NFS. After the
>> security
>> > key is generated, my box just waits there infinity. Its not starting a
>> new
>> > terminal.
>> > The new terminal has been specified in the inittab as
>> > ttyS0::respawn:/sbin/getty -L ttyS0 115200 vt100 # GENERIC_SERIAL
>> > Can anybody help me out with this problem?
>> > Since i am not able to set password i cannot do a secure
>> shell access too.
>> If I had to guess (since you didn't include any boot logs, that's
>> pretty much all I can do), I'd say that your NFS mount of the root
>> file system isn't working.
>> You can always try and see if you can even boot into a shell manually,
>> by adding init=/bin/sh to the kernel command line.
>> Have you tried booting without using NFS, and verifying that you can
>> mount the NFS volume?
>> --
>> Dave Hylands
>> Shuswap, BC, Canada
> --
> Regards,
> Prajosh Premdas
> _______________________________________________
> Kernelnewbies mailing list
> Kernelnewbies at

Hi Prajosh,

Could you post what exact error are you getting.
I had a very similar problem recently when trying to boot the kernel using
tftp and then mounting the Rootfs over NFS.
The issue I faced was that the Rootfs' /dev directory was not correctly
populated and was missing the /dev/console device.

I was getting an error on the lines of "Unable to start init console" and I
too spent time mucking about in my inittab.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Kernelnewbies mailing list