inittab is not executing after my Linux box boots up

Prajosh Premdas premdas.prajosh at
Tue Jun 14 13:22:44 EDT 2011

Hi Dave

I tried booting with the root file system in my flash and uImage i copy
using TFTP everything is fine.

On Tue, Jun 14, 2011 at 10:49 PM, Dave Hylands <dhylands at> wrote:

> Hi Prajosh,
> On Tue, Jun 14, 2011 at 10:07 AM, Prajosh Premdas
> <premdas.prajosh at> wrote:
> > Hi
> > I am stuck with a problem. inittab is not executing after my Linux box
> boots
> > up.
> > The problem in detail. I have a linux box, i load the Linux image uImage
> > using TFTP and my root file system is configured in NFS. After the
> security
> > key is generated, my box just waits there infinity. Its not starting a
> new
> > terminal.
> > The new terminal has been specified in the inittab as
> > ttyS0::respawn:/sbin/getty -L ttyS0 115200 vt100 # GENERIC_SERIAL
> > Can anybody help me out with this problem?
> > Since i am not able to set password i cannot do a secure
> shell access too.
> If I had to guess (since you didn't include any boot logs, that's
> pretty much all I can do), I'd say that your NFS mount of the root
> file system isn't working.
> You can always try and see if you can even boot into a shell manually,
> by adding init=/bin/sh to the kernel command line.
> Have you tried booting without using NFS, and verifying that you can
> mount the NFS volume?
> --
> Dave Hylands
> Shuswap, BC, Canada


Prajosh Premdas
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Kernelnewbies mailing list