Compiled Kernel stuck in booting

jim.cromie at jim.cromie at
Tue Sep 22 20:17:54 EDT 2020

On Wed, Jul 29, 2020 at 2:54 AM Yashodhan Joshi <yjdoc2 at> wrote:
> Hello,
> I use a dual boot laptop with windows and Ubuntu,with grub2.
> I Followed the instruction in to clone the source code and compile the kernel, which was done without any errors.
> When I tried to install the kernel using 'sudo make modules_install install' it showed a warning when updating initramfs, that it will attempt to resume from UUID, which is my SWAP space,
> but other than that it showed no other errors.
> When I tried to boot into it from the grub menu after restarting, it showed message of loading the kernel and then 'setting up intitial ramdisk', after which nothing further happend.

off the top of my head,
try editing the boot-config in grub, add a "1" or "S" on old redhat distros
to end of command line args.
that should drop you to root shell in emergency / maintenance mode.
(or it used to, I dont recall last time I did it,

I suspect you might hit that hang 1st, but its an easy enough test.

> The default kernel that came with ubuntu is still working and boots up into desktop environment withing 2-3 minutes after the 'ramdisk' message,
> but even though I kept the system running for 20 minutes after the 'ramdisk' message for the compiled kernel, niether any further proccess seems to be happening nor any error messages are shown.
> Can someone help me figuring out what is wrong and how can I run the kernel?
> Thank You.
> Also can someone point me in right direction to send suggestions about updating the information on kernelnewbies website?
> The information about connecting mutt to Gmail is quite outdated, and I would like to help updating it.
> _______________________________________________
> Kernelnewbies mailing list
> Kernelnewbies at

More information about the Kernelnewbies mailing list