Trouble Installing Compiled Kernel

Nathanael J Grix NathGri at
Wed Mar 25 12:52:27 EDT 2020

On Wednesday, March 25, 2020 12:38 PM, Valentin Vidić <vvidic at> wrote:

> On Wed, Mar 25, 2020 at 04:22:47PM +0000, Nathanael J Grix wrote:
> > After getting it compiled I ran:
> > bash-4.3$ sudo make O=/home/nathanael/KernelBuild/ install_module install
> This should be modules_install.
> ----------------------------------
> Valentin
> Kernelnewbies mailing list
> Kernelnewbies at

Sorry, that was just a typo I believe that I used modules_install and not install_module. I ran it again with modules_install just to be sure and still got the same error message:
bash-4.3$ make O=/home/nathanael/Kernel-5.6.0/ install_modules install
make[1]: Entering directory '/home/nathanael/Kernel-5.6.0'
make[1]: *** No rule to make target 'install_modules'.  Stop.
make[1]: Leaving directory '/home/nathanael/Kernel-5.6.0'
Makefile:180: recipe for target 'sub-make' failed
make: *** [sub-make] Error 2

If you have any other suggestions or resources that would be much appreciated. Thanks.

More information about the Kernelnewbies mailing list