Cannot read using USB Skeleton Driver

Greg KH greg at
Mon Sep 19 08:38:45 EDT 2011

On Mon, Sep 19, 2011 at 11:13:33AM +0530, Felix Varghese wrote:
> > Just do:
> >        modprobe usb_serial vendor=0x0000 product=0x0000
> > with the proper vendor and product ids for your device, then plug it in.
> >
> > No kernel changes needed at all, just have a pair of bulk in/out
> > endpoints and all will work automatically for you.
> Thanks Greg, I had thought that the usbserial driver would only work
> with proper CDC class virtual COM devices.
> I compiled it and tried it on my device and it worked fine! I was able
> to do bidirectional communication. So at least now I can be sure that
> one end is working. But the same device with the same firmware still
> doesn't work with the (customized) usb-skeleton. What could be wrong?

As I don't know what you customized exactly, nor how your hardware
exactly works, I could not say, sorry.

greg k-h

More information about the Kernelnewbies mailing list