Problem with booting newly compiled kernel

Shreyansh Jain shrey.linux at
Tue Dec 21 13:16:50 EST 2010

Hi List,

On Tue, Dec 21, 2010 at 7:22 PM, Prasad Joshi <prasadjoshi124 at> wrote:
> On Tue, Dec 21, 2010 at 1:37 AM, Alexandre Courbot <gnurou at> wrote:
>>>        linux   /vmlinuz-2.6.37-rc6+
>>> root=UUID=01432597-18e7-4609-9f85-3fad1d762ddc ro iommu=1
>> Try replacing root=UUID=01432597-18e7-4609-9f85-3fad1d762ddc by the
>> simpler root=/dev/sdaX. I had similar problems some time ago - for
>> some reason, my kernel did not like UUIDs.
> bravo Alexandre :)
> It solved the problem. I am really thankful to you.

Sorry to hijack your thread, but I thought this is the most opportune
time to ask my query.

@Prasad Nice to know that this suggestion solved the issue. I too have
found this issue very irritating but could never understand by UUID
were not recognized (where as my distro kernel recognizes them very

a. Does any have any idea which component causes this issue. As to,
what am I missing while compiling a new kernel that it doesn't
recognize the UUID of a dev disk?

b. Also, who generates these UUID - is it a disk property (like, ROM
signature or stuff?), or this is some udev magic?

Thanks to anyone who can provide any hint about this.


More information about the Kernelnewbies mailing list