[gfp] why apparent asymmetry in the double-underscore prefix convention in alloc_pages/__free_pages, etc.?
May 16, 2014
5:15 a.m.
I thought this question should have been asked before; but I cannot find an answer despite several search attempts. So I ask. I am curious about the apparent asymmetry in the naming convention of the "alloc_pages/__free_pages" and "__get_free_pages/free_pages" pairs. The former pair works on "struct page" while the latter pair works on "unsigned long" I understand that double-underscore prefixes "__" in kernel is a convention for reminder ("make sure you know what you are doing"); how does this convention apply to explain the apparent asymmetry? Wei.
4474
Age (days ago)
4474
Last active (days ago)
0 comments
1 participants
participants (1)
-
Wei Peng