Debugging i2c : i2cdetect cant detect a device on i2c line

Raul Piper raulpblooper at
Wed Sep 6 22:51:44 EDT 2023

Hello ,
I am trying to detect an i2c device A on i2c1 line on  one of the Arm
Cortex A7 platform but not able to see any device on a given address (
0x3d) .

Is there any parameters of i2c which i can change like rise/fall time
, timeout etc in a device tree or kernel source and re test it?
I have tried changing the i2c speed from 100KHz to 400 KHz  but no success.
I have even tried removing the 1.5K pull ups on the i2c lines but no result.

So I wanted to know on what factors i2cdetect may not probe the device
or show it on the hex dump.
What parameters of i2c driver i can tinker and where? Is Platform dts
is the only file i can modify and test with?
Kernel is 5.51 .
There are other 2-3 devices on the same lines which responds to
i2cdetect with correct address but not this device (0x3D) .
Its i2c address is also different from the current devices.


More information about the Kernelnewbies mailing list