USB driver

Sohaib Mhmd xunilams at
Sat Apr 25 01:44:12 EDT 2020

Hi everyone, I made a very simple USB driver
but the problem is that the probe and disconnect functions never was called.
I tried to google for this problem but unfortunately:
1- I don't use usb-storage <>,
it's a keyboard! (but anyway the same problem exists with any usb-based
device) and all driver on my machine are  bluetooth related drive (i
think!) (as you see from lsmod | grep usb)
2- I tried to rmmod usbhid <>
but I get error: ERROR: Module usbhid is builtin.
I tried to search for "usbhid" in .config file to remove it but I didn't
find anything.

What should I do?
thanks, smalinux

[root at hp kernel_mod]# lsmod | grep usb
sma_usb                16384  0
btusb                  57344  0
btrtl                  24576  1 btusb
btbcm                  20480  1 btusb
btintel                32768  1 btusb
bluetooth             634880  34 btrtl,btintel,btbcm,bnep,ath3k,btusb,rfcomm

I use  :
- Linux hp 5.6.3 #2 SMP Fri Apr 10 06:45:27 EET 2020 x86_64 x86_64 x86_64
- Linux buildroot 5.4.3-gf7688b48a-dirty #1 SMP Thu Jan 1 00:00:00 UTC 1970
x86_64 GNU/Linux
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Kernelnewbies mailing list