ZRAM setup and configuration

russel phillipe russel.phillipe at gmail.com
Wed Oct 18 02:22:59 EDT 2017

I am trying to setup ZRAM on ubuntu 4.4 kernel. I can load and create zram
based swap devices fine as you can see below.

# apt-get install zram-config

cat /proc/swaps
Filename Type Size Used Priority
/dev/sda3 partition 16638972 0 -1
/dev/zram0 partition 2036816 0 5
/dev/zram1 partition 2036816 0 5
/dev/zram2 partition 2036816 0 5

How can I make it work. I tried running memtester and load it with stress
stress --vm-bytes $(awk '/MemFree/{printf "%d\n", $2 * 0.9;}' <
/proc/meminfo)k --vm-keep -m 1

It does not look like it is being used.

I notice that 'used' count in /proc/swaps does not bump at all. I even
tried 'vmstat 1 100 ' while running stress and memtester and did not see
any change in SO and SI.
What am I missing?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.kernelnewbies.org/pipermail/kernelnewbies/attachments/20171017/ae303b2d/attachment.html 

More information about the Kernelnewbies mailing list