Zram not working on a different Android version

Leandro M Barbosa lbarbosa at linux.com
Tue Feb 3 10:37:01 EST 2015

Hello all,

I'm testing zram on Android. Testing using stock kitkat (Android
4.4.2) version in a Samsung S4 went well and I was able to make
modifications and use my modified kernel on it just fine, as well as
using a custom compiled unmodified version.

I then, installed Cyanogenmod (Android 4.4.4) and installed a custom
compiled unmodified kernel version in it. However, running the same
benchmark tests that I ran for the stock version didn't make zram get
pages. I was able to use about 70% or more memory and no swap spaced
was used.

I'm checking /sys/block/zram0/mem_used_total (and related) and
/proc/swaps. There seem to be no difference between the two test
scenarios. I made tests using the same compiled kernels in both
Android version with the same results: works on stock, does not work
on Cyanogenmod. I tried to reach the xda-developers to no avail. There
must be some runtime kernel configuration differences between the two
scenarios. Anyone able to point me towards the right direction?

Thanks in advance.

Leandro Moreira Barbosa

More information about the Kernelnewbies mailing list