Confused by function names cpuidle_install_idle_handler/cpuidle_uninstall_idle_handler
Mohammad Merajul Islam Molla
meraj.enigma at gmail.com
Fri Jul 18 12:07:20 EDT 2014
Hello,
In drivers/cpuidle/cpuidle.c, there are two functions
cpuidle_install_idle_handler & cpuidle_uninstall_idle_handler. The
names seem confusing to me as they don't install any handler, rather
set 'initialized' variable to 1/0.
In v3.0 kernel, these functions used to look as below where they
installed and uninstalled some handler function -
void cpuidle_install_idle_handler(void)
123 {
124 if (enabled_devices && (pm_idle != cpuidle_idle_call)) {
125 /* Make sure all changes finished before we switch
to new idle */
126 smp_wmb();
127 pm_idle = cpuidle_idle_call;
128 }
129 }
void cpuidle_uninstall_idle_handler(void)
135 {
136 if (enabled_devices && pm_idle_old && (pm_idle != pm_idle_old)) {
137 pm_idle = pm_idle_old;
138 cpuidle_kick_cpus();
139 }
140 }
Do these names (and corresponding comments) still hold?
--
Thanks,
-Meraj
More information about the Kernelnewbies
mailing list