[alsa-devel] USB audio Gadget - code 10 error

Eamon Hayden eamon.hayden at cloudiumsystems.com
Mon Jun 10 03:41:46 EDT 2013

Yes, I only have this problem with Windows (versions 7 and 8 are the ones I have tried).

I don't have this problem on Linux - or more specifically I don't have the issue on Ubunto 12.0.4

Is there anybody that has tried this with windows?


-----Original Message-----
From: Jonathan Neuschäfer [mailto:j.neuschaefer at gmx.net] 
Sent: Wednesday, June 05, 2013 7:46 PM
To: Eamon Hayden
Cc: 'Jassi Brar'; 'anish singh'; alsa-devel at alsa-project.org; 'kernelnewbies'
Subject: Re: [alsa-devel] USB audio Gadget - code 10 error

On Wed, Jun 05, 2013 at 06:08:36PM +0100, Eamon Hayden wrote:
> Just to be sure...
> I just downloaded a clean copy of kernel 3.6.9. 
> I then configured it for UAC1 and the USB Audio Gadget. 
> I rebuilt and installed the g_audio loadable module.
> Again I get the 'This device cannot start (code 10)' Error when I 
> connect windows 7.
> My expectation is that that this should work with the default windows 
> drivers - Is this correct.

This seems to be a problem you have with Microsoft Windows 7, is that correct?

Or do you rather get the error message 'This device cannot start (code 10)' on Linux? If so, please post a more complete error log.
Also, the output of "lsusb -v" might help.

Jonathan Neuschäfer

More information about the Kernelnewbies mailing list