[alsa-devel] USB audio Gadget - code 10 error

Eamon Hayden eamon.hayden at cloudiumsystems.com
Wed Jun 5 13:08:36 EDT 2013

Just to be sure...
I just downloaded a clean copy of kernel 3.6.9. 
I then configured it for UAC1 and the USB Audio Gadget. 
I rebuilt and installed the g_audio loadable module.

Again I get the 'This device cannot start (code 10)' Error when I connect windows 7.

My expectation is that that this should work with the default windows drivers - Is this correct.

Thanks for your help.

-----Original Message-----
From: kernelnewbies-bounces at kernelnewbies.org [mailto:kernelnewbies-bounces at kernelnewbies.org] On Behalf Of Eamon Hayden
Sent: Wednesday, June 05, 2013 8:42 AM
To: 'Jassi Brar'; 'anish singh'
Cc: alsa-devel at alsa-project.org; 'kernelnewbies'
Subject: RE: [alsa-devel] USB audio Gadget - code 10 error

I've tried both UAC1 and UAC2 at this stage and both give the same result.

-----Original Message-----
From: Jassi Brar [mailto:jassisinghbrar at gmail.com]
Sent: Wednesday, June 05, 2013 4:29 AM
To: anish singh
Cc: Eamon Hayden; alsa-devel at alsa-project.org; kernelnewbies
Subject: Re: [alsa-devel] USB audio Gadget - code 10 error

> On Tue, Jun 4, 2013 at 10:35 PM, Eamon Hayden 
> <eamon.hayden at cloudiumsystems.com> wrote:
>> I’m trying to use the linux usb audio gadget but I get the error : 
>> “This device cannot start (code 10) when I connect to a windows 7/8 
>> box. I don’t have this problem when I connect to ubunto 12.0.4
You didn't tell if you are trying UAC1 or UAC2 ?  The latter won't work as such because iirc Windows don't support UAC2 natively (you'll have to load some 3rd part divers).


Kernelnewbies mailing list
Kernelnewbies at kernelnewbies.org

More information about the Kernelnewbies mailing list