Error Creating GIT Repo

Paul Waring lists at
Sat Aug 31 06:29:17 EDT 2013

On Fri, Aug 30, 2013 at 07:04:54AM +0530, Arun M Kumar wrote:
> I have tried this multiple times with the same result.
> git clone 
> git://
> Cloning into 'linux-stable'...
> remote: Counting objects: 3359873, done.
> remote: Compressing objects: 100% (513049/513049), done.
> fatal: read error: Connection timed out), 189.03 MiB | 100 KiB/s
> fatal: early EOF
> fatal: index-pack failed

Try cloning with the argument --depth 1, i.e.

git clone --depth 1 <git URL>

That should give you a shallow clone which will contain all the files,
but not the history, and you won't be able to push changes. If you need
that information, you can update after cloning by running the following
command within the linux-stable directory:

git fetch --depth=2147483647

If you have a recent (>= 1.8.3 I think) version of Git you may also be
able to run:

git fetch --unshallow

Which is an alias for --depth=2147483647, but easier to remember.[1]


Paul Waring

More information about the Kernelnewbies mailing list