using sizeof operator
Daniel Baluta
daniel.baluta at gmail.com
Sun Jan 22 13:27:13 EST 2012
On Sun, Jan 22, 2012 at 8:14 PM, Sukrit Sangwan <sukritsangwan at gmail.com> wrote:
> There are instances in the code where sizeof(*ptr) is used. e.g.
> in net/802/garp.c
> const struct garp_msg_hdr *gm;
> if (!pskb_may_pull(skb, sizeof(*gm)))
> return -1;
> i want to ask is there any sense in using sizeof(struct garp_msg_hdr)
> instead of sizeof(*gm) in the above example.
Imagine what would happen if you change the name of struct garp_msg_hdr;
thanks,
Daniel.
More information about the Kernelnewbies
mailing list