Trouble running Custom kernel

Alexandre Courbot gnurou at
Tue Jan 18 00:41:54 EST 2011

> I compiled a custom kernel on a virtual box and wen i try to boot the kernel , It says "udev:Wating for device /dev/sda1"and then after 10 seconds it drops to ramfs shell .
> I think this is a configuration mistake .
>  I tried to make the kernel with the distro specific .config file from /proc/config.gz , But it still doesn't respond .

Two possible hints:

1) Do you pass the correct "root=" option to your kernel?

2) (more likely) Distro-built kernels usually only include a minimal
set of features built-in and heavily rely on modules to better suit
the multitude of different hardware and usage cases they may face at
runtime. For this reason many disk controllers and file systems are
built as modules, and the distro makers include the ones that will
likely be needed at boot time into an initrd file that is passed to
the kernel upon boot.

In your case it may be that your kernel lacks support for your root
filesystem and requires a module for it. Try creating an initrd file
for your kernel using mkinitrd or mkinitramfs (depends on your
distro), and pass it to your kernel (look at grub's menu.lst to see
how this is done). Be aware that you cannot use one of the initrd's
provided by your distro for that, as the modules will not be
compatible with your kernel.

A more complete boot log would be welcome if none of these ideas are
related to your problem.

Hope this helps.

More information about the Kernelnewbies mailing list