Kernel compilation

scott redhowlingwolves at
Wed Jan 5 00:34:32 EST 2011

I'm new to the list and would like to say hello to everyone. Now on to 
the meat.

I have tried to compile a kernel with a grsec patch 5 times now using a
couple of different methods and I keep getting a "No init found" and
"Couldn't support optional features" errors every time at bootup.
I'm trying to use a vanilla kernel on 10.04 Ubuntu and it 
compiles fine,
just will not boot.

I've tried "CONCURRENCY_LEVEL=`getconf _NPROCESSORS_ONLN` fakeroot make-kpkg
--initrd --append-to-version=-custom kernel_image kernel_headers",
"CONCURRENCY_LEVEL=3 make-kpkg --initrd --append-to-version=-586
kernel_image kernel_headers modules_image".

I have all the reqs for building kernels such as build-essentials, fakeroot,
kernel-package, kernel-wedge, nurces-dev and qt for xconfig.

These are the steps I've taken. DL the kernel image from, get
the patch from, untar the kernel, cd into the directory created,
do a 'cp /boot/config-`uname -r` .config', 'make oldconfig', apply the
patch, then either 'make menuconfig' or 'make xconfig'. Then I do a
'make-kpkg clean' and run one of the commands in the first paragraph above.

I get the debs built and can install them just fine, but I keep getting the
same errors. I've cut out as many "Experimental" options I thought might
cause a problem and still get a kernel panic at boot.

Anyone have a clue what I'm doing wrong?

More information about the Kernelnewbies mailing list